Fandom Developers Wiki
Advertisement
Fandom Developers Wiki

This article is about a system or feature that is no longer in use.

The page is retained for historical reasons.

Reason: Collapsing is a default feature of MediaWiki

ShowHide is a script for collapsible tables and divs. It was in use before core MediaWiki collapsibles existed, but should no longer be installed on wikis. If you used this feature, you can search for collapsible (replaced with mw-collapsible) or NavFrame classes in your wiki and replace them with equivalent classes in the new collapsibles.

Deprecation

As ShowHide has been deprecated for over 5 years, wikis might be interested in migrating from it to the regular collapsing feature. For that purpose, a warning feature has been added to ShowHide that warns users when the wiki is using ShowHide and listing the elements that use deprecated classes in their JavaScript console. There is also a banner notification appearing only for administrators and content moderators across whole Template and MediaWiki namespaces when ShowHide is imported, and elsewhere when deprecated classes are in use on the page. Upon dismissing the banner notification, it won't show up for the next 6 months.

To enable the feature, place this piece of JavaScript in your personal JavaScript page:

window.ShowHideDisplayWarning = true;

This particular setting cannot be enabled site-wide and is only used to help migrating over to the core MediaWiki feature.

Advertisement