FANDOM


This is the talk page for discussing improvements to the UserTags/Archive 2 page.

Emailconfirmed tag text displays oddly.

Just set up emailconfirmed so that it appears properly over at the Helmet Heroes Wikia, and it's displaying the text very oddly. I would've thought it would say "EMAIL CONFIRMED", but it says "¿EMAILCONFIRMED?". Is this a bug? 404UserNotFound (talk) 21:05, October 12, 2013 (UTC)

Ah, I just checked the source code of the tag using FireBug, and saw the following:
   <span class="tag usergroup-emailconfirmed emailconfirmed-user" title="No Tag Information. Broken module or bad configuration!">¿emailconfirmed?</span>
So that's why it's broken. 404UserNotFound (talk) 21:06, October 12, 2013 (UTC)
UserTagsJS.modules.mwGroups does not contain 'emailconfirmed' in your config TK-999 (talk) 00:28, October 13, 2013 (UTC)
It did earlier, but I've since removed it because it was bugged. 404UserNotFound (talk) 02:06, October 13, 2013 (UTC)

This doesn't show tags on Message Walls

Just realized this. Take Rappy_4187's Message Wall for example. If you check his user page, you'll see he's Staff/Utilities, and you'll see the customized tags I've set up for those groups. However, on his Message Wall, it only shows the generic STAFF tag. I believe the fix for this is a simple modification, but I'm no JS expert, so hopefully this can be updated to show the tags on the Message Wall page. 404UserNotFound (talk) 08:16, October 17, 2013 (UTC)

Fixed.-- ~ UltimateSupreme 13:56, October 17, 2013 (UTC)
Wonderful, everything is working again! Thanks UltimateSupreme :D 404UserNotFound (talk) 19:51, October 17, 2013 (UTC)

MHFanon's tags aren't working...

We have all the scripts installed and configured, yet, it doesn't seem to work.

http://monsterhunterfanon.wikia.com/wiki/MediaWiki:Wikia.js

http://monsterhunterfanon.wikia.com/wiki/MediaWiki:Wikia.css

http://monsterhunterfanon.wikia.com/wiki/MediaWiki:Common.css

http://monsterhunterfanon.wikia.com/wiki/MediaWiki:Common.js

http://monsterhunterfanon.wikia.com/wiki/MediaWiki:Monobook.css

http://monsterhunterfanon.wikia.com/wiki/MediaWiki:Monobook.js

MasterCeadeus 21:54, December 8, 2013 (UTC)

Import the script only in Common.js, not all.
Also there is this: Error: JavaScript parse error: Parse error: Unexpected token; token } expected in file 'MediaWiki:Common.js' on line 145--~UltimateSupreme 10:29, December 9, 2013 (UTC)
I couldn't find the error... but I did fix the imports. MasterCeadeus 22:47, December 9, 2013 (UTC)
You're missing a comma here:
UserTagsJS.modules.custom = {
	'Master Ceadeus 27': ['test1', 'aauthor', 'mauthor', 'ffauthor'] 
        'Setheo': ['mwdesign', 'gigas', 'aauthor', 'mauthor', 'ffauthor']
};
It should look like this (note the comma at the end of the first line):
UserTagsJS.modules.custom = {
	'Master Ceadeus 27': ['test1', 'aauthor', 'mauthor', 'ffauthor'],
        'Setheo': ['mwdesign', 'gigas', 'aauthor', 'mauthor', 'ffauthor']
};
RyaNayR (talkcontribs) 11:28, December 10, 2013 (UTC)
I'm also pretty sure you need to add all those custom tags to UserTagsJS.modules.mwGroups and you need to have window.UserTagsJS above it. —RyaNayR (talkcontribs) 12:39, December 10, 2013 (UTC)
I think I fixed it, but it's not showing up... MasterCeadeus 23:19, December 10, 2013 (UTC)

Tags not showing up?

This is my current coding, placed in the Common.js page of the Shadowhunters' wiki. I am particularly concerned about the Bureaucrat & Rollback tags. What did I do wrong?

window.UserTagsJS = {
	modules: {
			inactive: 30,
			mwGroups: ['bureaucrat', 'chatmoderator', 'patroller', 'rollback', 'sysop', 'bannedfromchat', 'bot', 'bot-global'],
			autoconfirmed: true,
			metafilter: {
				sysop: ['bureaucrat'],
				chatmoderator: ['sysop'],
				rollback: ['sysop'],
			},
			newuser: true,},
	tags: {
		bureaucrat: { u:'Consul', link:'Administrators' },
		sysop: { link:'Administrators' },
		rollback: { u:'Rollback', link:'Administrators' },
			}
};
UserTagsJS.modules.custom = {
	'Redwall64': ['bureaucrat'],
};
UserTagsJS.modules.mwGroups = ['bureaucrat']; 
UserTagsJS.modules.mwGroups = ['rollback'];
importArticle({type:'script', article:'w:c:dev:UserTags/code.js'});

I have also placed codes on the Wikia.css and Monobook.css, as instructed on the page. ~ redwall64 12:03, December 29, 2013 (UTC)


Hello. test with this script :

window.UserTagsJS = {
	modules: {}
	tags: {
		bureaucrat: { u:'Consul', link:'Administrators' },
		sysop: { link:'Administrators' },
		rollback: { u:'Rollback', link:'Administrators' }
	}
};
UserTagsJS.modules.mwGroups = ['bureaucrat', 'rollback', 'chatmoderator', 'patroller', 'sysop', 'bannedfromchat', 'bot', 'botglobal'];
UserTagsJS.modules.autoconfirmed = true;
UserTagsJS.modules.inactive = 30;
UserTagsJS.modules.newuser = true;
UserTagsJS.modules.metafilter = {
	sysop: ['bureaucrat'],
	rollback: ['sysop'],
	chatmoderator: ['sysop']
};
importArticle({type:'script', article:'w:c:dev:UserTags/code.js'});

I've never seen anything in "modules: {}" in the beginning of the script, so i've moved the modules in the end =) I've also deleted the "custom" module, which is useless, because the "mwgroup" module add the "bureaucrat" tag automatically.

   Maxime  Discuter  Contributions    14:18, December 29, 2013 (UTC)

Still nothing, it seems. ~ redwall64 11:50, December 31, 2013 (UTC)
Hey there! Please try this one:
window.UserTagsJS = {
    modules: {
        inactive: 30,
        mwGroups: ['bureaucrat', 'chatmoderator', 'patroller', 'rollback', 'sysop', 'bannedfromchat', 'bot', 'bot-global'],
        autoconfirmed: true,
        metafilter: {
            sysop: ['bureaucrat'],
            chatmoderator: ['sysop'],
            rollback: ['sysop']
        },
        newuser: true,
        custom: {
            'Redwall64': ['bureaucrat']
        }
    },
    tags: {
        bureaucrat: {
            u: 'Consul',
            link: 'Administrators'
        },
        sysop: {
            link: 'Administrators'
        },
        rollback: {
            u: 'Rollback',
            link: 'Administrators'
        }
    }
};
 
importArticle({
    type: 'script',
    article: 'w:c:dev:UserTags/code.js'
});

Hope this helps! :D—An[matedCar]oons 12:07, December 31, 2013 (UTC)

Inactive Tag

First, w:c:alvin:MediaWiki:Common.js. I have customized where when someone is a new editor, they lose the tag when they become inactive (no editing to main, talk, thread, and board thread in the last 45 days). However, for example, here and here they are for some reason not inactive (they have no edits in over three years) yet here and elsewhere others are inactive. DEmersonJMFM 03:21, January 10, 2014 (UTC)

In need of assistance with user tags

Hi, I really need help with getting the user tags to show up at my wiki. This is my MediaWiki:Common.js at the moment. Perhaps you should take a look at my MediaWiki:Wikia.css as well. I know I must have screwed up with the user tag coding somehow but I cannot figure it out at all and it's giving me a headache. In addition, other scripts, such as auto-refresh, display timer, and referencepopups do not work either. I would really appreciate any help regarding this matter. Thank you in advance.--C. Phantom 20:54, February 17, 2014 (UTC)

You're missing a comma here:
UserTagsJS.modules.metafilter = {
	sysop: ['bureaucrat', 'founder'], // Remove administrator group from bureaucrats
	bureaucrat: ['founder']
	chatmoderator: ['sysop', 'bureaucrat']
};
It needs to go at the end of the bureaucrat: ['founder'] line. One little error in Common.js will break the whole thing, so that's why the other scripts aren't working. Once you add that comma everything should work again. —RyaNayR (talkcontribs) 22:42, February 17, 2014 (UTC)
Thank you very much, I've adjusted it accordingly, now I'll just wait for the changes to set in. Thanks again.--C. Phantom 02:43, February 21, 2014 (UTC)

Stopped working

Hi, this script seems to have stopped working at w:c:bloons, despite no recent editing of w:c:bloons:MediaWiki:Common.js. I've had a look at other wikis, and the script seems to be functioning on all of them. Not sure what could be wrong. Any help is appreciated. — SW8573 (Talk) 08:35, February 22, 2014 (UTC)

Hi, we had found a script being in conflict with UserTags, so the issue has been solved. -- Spike144 (talk) 16:27, March 10, 2014 (UTC)

Staff tag not showing up

After changing MediaWiki:User-identity-box-group-staff from "Staff" to "Wikia Staff" UserTags stops the staff tag from appearing

The code I"m using:

window.UserTagsJS = {
	modules: {},
	tags: {
		sysop: { u:'Administrator', order:-1/0 },
		newuser: { u:'New Rust Wiki Editor' },
		headadmin: { u:'Head-Administrator', order:-1/0 },
		vstf: { link:'Help:SpamTaskForce' },
		staff: { link:'http://community.wikia.com/wiki/Community_Central:Staff' }
	},
	oasisPlaceBefore: ''
};
UserTagsJS.modules.mwGroups = ['bureaucrat', 'sysop', 'rollback', 'bannedfromchat', 'staff'];
UserTagsJS.modules.metafilter = {
	'newuser': ['sysop', 'bureaucrat', 'bot'],
	'notautoconfirmed': ['sysop', 'bureaucrat', 'bot'],
	'headadmin': ['founder']
};
UserTagsJS.modules.implode = {
	'headadmin': ['sysop', 'bureaucrat']
};
UserTagsJS.modules.inactive = {
	days: 60,
	namespaces: [0],
	zeroIsInactive: true // 0 article edits = inactive
};
UserTagsJS.modules.autoconfirmed = true
UserTagsJS.modules.newuser = {
	days: 5, // Must have been on the Wiki for 5 days
	edits: 10, // And have at least 10 edits to remove the tag
	namespace: 0 // Edits must be made to articles to count
};

Jdm280 (talk) 01:25, May 17, 2014 (UTC)

The wiki in question?--~UltimateSupreme 11:28, May 21, 2014 (UTC)
It's the Rust Wiki
Here is a link to the All Pages MediaWiki Namespace for convenience: link
Jdm280 (talk) 01:12, May 23, 2014 (UTC)
I can see the staff tag here
Note that the staff tag does not appear in monobook.~UltimateSupreme 04:52, May 23, 2014 (UTC)
Yes but that is because I have changed it back to the default "Staff" since then. If I change it to anything else the tag will not appear however, disabling UserTags fixes this.
Jdm280 (talk) 02:51, May 27, 2014 (UTC)

Banned from chat tag

Hi, I'm using this on my global.js, but any user who is banned from chat and hasn't got a lot of edits has the "Banned from Chat" tag overwritten by New Editor. How do I go about displaying both at once? My global.js is here if needed: w:User:SuperSajuuk/global.js. Thanks. --SuperSajuuk Talk Page | Tabber Code | Channel 20:13, July 4, 2014 (UTC)

Hi, it looks like you applied a fix for that, but the script import is commented out so you'll have to uncomment the script to see if it worked. Also if it doesn't, try reversing 'newuser' and 'bannedfromchat' in newuser: ['bannedfromchat']RyaNayR (talkcontribs) 20:23, July 04, 2014 (UTC)
The fix I tried didn't work, your suggestion also didn't work. If any other suggestions can be found, would appreciate it. :) --SuperSajuuk Talk Page | Tabber Code | Channel 20:59, July 4, 2014 (UTC)
It seems bannedfromchat is no longer available now. It just shows an error USERTAGS(M:OasisTagsModule): Scraped tag was not claimed: Banned From Chat--~UltimateSupreme 09:25, July 6, 2014 (UTC)

Various customization attempts making all tags disappear

Basic setup of UserTags was easy, but I am having what seem like some dumb simple problems when trying most of the customization. Turning Admin and Bureucrat tags into links works, so I can be sure I'm adding configuration options to the right place of the right file, at least.

I was trying to get it to show the Admin tag for a bureaucrat. For testing purposes I also tossed in "Inactive".

UserTagsJS.modules.custom = {
	'WonderBuono!': ['sysop', 'inactive']
};

This did indeed cause both the Admin and Inactive tags to show for her... but it made Bureaucrat stop appearing. It also made every other tag from UserTags stop appearing for everyone else. Commented that out.

I tried adding the ability for users to choose which languages they know.

UserTagsJS.modules.prefLanguages = true;

This seemed to work, as far as adding the link to "My scripts" and giving me an EN-5 tag once I'd identified as a native English speaker. However, again all the other UserTags tags disappeared. Commented that out.

Since it's true for almost every user I find the "AUTOCONFIRMED USER" tag much more of an eyesore than it's worth, so I tried making it go away like so:

UserTagsJS.modules.metafilter = {
	'autoconfirmed': ['autoconfirmed']]
};

Again the result was that every UserTags tag disappeared. This time the Admin tag wasn't even a link any more. JoshuaJSlone (talk) 10:06, August 4, 2014 (UTC)

Tried setting it up on another fresher wiki where there shouldn't be other scripts to conflict with it. Again the prefLanguages made other tags disappear. Does anyone have this working properly so I can look at your MediaWiki files? JoshuaJSlone (talk) 18:35, August 11, 2014 (UTC)

Need Help

Hello I need help on giving me a Founder title because I am the original founder but it says my other account is and I am not so good with CSS and I put

// Custom User Tags /* Setting up tags */window.UserTagsJS = { modules: {}, tags: { founder: { order: -1 }, 'BeyonderGod': { u: 'Founder', order: 1 } } }; /* Founders */UserTagsJS.modules.custom = {

'BeyonderGod': ['founder', 'sysop'],

And nothing changed is there i way I can make the founder title show? —Preceding unsigned comment added by Groyolo (talkcontribs) . Please sign your posts with ~~~~!

There is no such thing as a founder group. It can only be placed on the user account used to create the wiki and it can't be changed. --SuperSajuuk Talk Page | Tabber Code | Channel 13:50, August 5, 2014 (UTC)

newuser tag

So I'm using the newuser module and I'd like to make it so that the "newuser" tagged gets removed if "bannedfromchat" is present. However, my metafilter code isn't working. I think this might come back to my previous question about the 'bannedfromchat' tag above, but just want to check if this would be valid:

'newuser': ['bannedfromchat']

Thanks for any help (if any) for this issue. --SuperSajuuk Talk Page | Tabber Code | Channel 15:37, August 29, 2014 (UTC)

removed when blocked bug

I believe i have found a bug with the remove when blocked module,when you ban a user from chat,it not only removes all user tags,but it also removes the banned from chat user tag.

Rider ranger47 19:52, September 26, 2014 (UTC)

The bannedfromchat tag hasn't worked for a while unfortunately, I believe because it expects it to be a user right (which it was, but isn't anymore). It's also the likely cause of the bug just above your report too. cqm 10:09, 27 Sep 2014 (UTC)

Tag error

I recently added some more modules to my wikis common.js file:

//Usertags config
window.UserTagsJS = {
	modules: {},
	tags: {
sysop: { link:'Project:Administrators ' },
rollback: { u:'Bagger' },
bot: { link:'Help:Bots' },
}
};
UserTagsJS.modules.isblocked = true;
 
UserTagsJS.modules.mwGroups = ['bot', 'bot-global', 'rollback'];
 
UserTagsJS.modules.inactive = {
	days: 60,
	namespaces: [0],
	zeroIsInactive: true
};
UserTagsJS.modules.metafilter = {
	'rollback': ['sysop'],
};
UserTagsJS.modules.autoconfirmed = true;
 
UserTagsJS.modules.implode = {
	'Administrative Bot ': ['sysop', 'bot']
};

importArticle({type:'script', article:'w:c:dev:UserTags/code.js'});

And the implode function is not working correctly. When the tag is displayed, it has 2 question marks in front and at the end of it, which can be seen here: [1] Can anyone tell me why this is happening? Everything else is working correctly. -- Rider ranger47 22:41, November 3, 2014 (UTC)


I having a bit of trouble...

Hi, I've been experimenting with this page and it seems I'm having some issues.

How do I have the Admin tag be hidden for Bureaucrats, and the Bureaucrats-specific tag be visible for them?

Thanks. HoneyCandiez (talk) 20:55, February 10, 2015 (UTC)

Please add a link to the wiki. Arkondi (talk) 21:29, February 10, 2015 (UTC)
If I remember correctly, it was Youtube Wiki. Underscorre (talk) 09:58, February 11, 2015 (UTC)
At first the css rule in lines 43 to 50 on w:c:youtube:MediaWiki:Common.js should be removed. It prevents the execution of the JS code. Arkondi (talk) 13:19, February 11, 2015 (UTC)
It was the YouTube wiki. The code was removed but it doesn't appear to have worked. HoneyCandiez (talk) 23:49, February 11, 2015 (UTC)
You also removed lines 42 and 51 with your first edit. The last part should look like this:
importArticles({
    type: 'script',
    articles: [
        //other scripts,
        'u:dev:MessageWallUserTags/code.js'
    ]
});
Arkondi (talk) 05:00, February 12, 2015 (UTC)
I'm sorry this pattern keeps happening, but it stil has not worked. HoneyCandiez (talk) 16:53, February 12, 2015 (UTC)
Because you forgot to delete a line. :)
Replace
 addOnloadHook(UserNameReplace);
 
});

importArticles({
with
addOnloadHook(UserNameReplace);
 
importArticles({
Arkondi (talk) 17:45, February 12, 2015 (UTC)
Nothing. It didn't work. Do I have to do anything in a different part of the MediaWiki? HoneyCandiez (talk) 23:03, February 14, 2015 (UTC)
The problem is now, that you try to change the undefined variable UserTagsJS. Replace
UserTagsJS.modules.userfilter = {
    'Purzyckij': ['sysop'],
    'placeholder name 2': ['sysop'],
    'placeholder name 3': ['sysop']
};
 
UserTagsJS.modules.mwGroups = ['Bureaucrat'];
with
window.UserTagsJS = {
  modules: {
    userfilter: {
      'Purzyckij': ['sysop'],
      'placeholder name 2': ['sysop'],
      'placeholder name 3': ['sysop']
    },
    mwGroups: ['Bureaucrat']
  }
}
Arkondi (talk) 23:37, February 14, 2015 (UTC)

Where to add the code?

Where should the code on this page added? On MediaWiki:Commons.js?

Thanks!

NemiS Message Wall 17:57, February 25, 2015 (UTC)

Yes, but there is some code that has to go on a css page too... -- Sophie ✪ Profile Talk/Message Wall Contributions 23:29, December 5, 2015 (UTC)

Banned from Chat Tag disappearing

For some reason, the banned from chat tag keeps on dissappearing:

Code: MediaWiki:Common.js

Banned from Chat User: User

 Nicko756 (TC)  18:18, April 5, 2015 (UTC) 

custom tag get covered by usertags tags

I used this code:

/******************** Level system ********************/
//When looking at a user profile page,
if ($("#UserProfileMasthead").size()) {
    //get the displayed editcount,
    editCount = $("#UserProfileMasthead .tally em").html().replace(",","");
    //compare it to a predefined list of levels,
    editRanks = {
    1:"LEVEL 1",
    10:"LEVEL 2",
    25:"LEVEL 3",
    50:"LEVEL 4",
    90:"LEVEL 5",
    ...
    76350:"LEVEL 46",
    81535:"LEVEL 47",
    86950:"LEVEL 48",
    93110:"LEVEL 49",
    100000:"LEVEL 50",
    };
    for(i in editRanks) if (editCount >= parseInt(i)) editRank = editRanks[i];
    //and display the corresponding level as a tag.
    if (editCount) $($("<span>").addClass("tag").html(editRank)).appendTo(".masthead-info hgroup");
}

Either I put it before import usertags script or after it in my Common JS, the level system tag disappears right before usertags tags are loaded. This makes me unable to see the level system tag.

Try importing this script and you'll see it. How to resolve this? --yhynerson1 (talk, contribs) 14:40, April 28, 2015 (UTC)

Banned from Chat Tag only shows up for one second

The Banned from chat tag only shows up for one second on banned users, before it disappears. And I don't know how to fix it.

Here is my Common.js. -- C.Syde (talk | contribs) 05:43, May 23, 2015 (UTC)

Tag coloring not working

Hi, I'm Legofan100, an administrator on the Poptropica Wiki. I tried changing the colors of some tags and it is not working. the js the css

Thanks, Legofan100

When editing CSS, make sure you're looking out for red warning symbols for your code. I fixed this by closing a previous selector here. Rappy @fandom 14:23, July 3, 2015 (UTC)

Global User Tags Bug with User Tags enabled

I find it weird how with user tags enabled, RansomTime, TK-999, Abuse Filter, and Monchoman45 have the administrator tag on all wikis, while TyA, CallofDuty4 and Sactage have the chat moderator tag on all wikis. And I've never found any explanation as to why that bug exists. I don't find this particular bug to be a major problem, but then again I've always wondered if there was anything that could be causing the bug to occur. ― C.Syde (talk | contribs) 05:24, July 9, 2016 (UTC)

It happens to another user (User:Robin Patterson) who has no flags at all on Wikia. Not a major problem though. --Sajuuk 18:40, July 9, 2016 (UTC)
The user doesn't even exist according to their masthead. ― C.Syde (talk | contribs) 22:51, July 9, 2016 (UTC)
I typo'ed the user's name, fixed. --Sajuuk 15:24, July 13, 2016 (UTC)

Where does this happen?

The "walkthrough" section excludes where you go to type that coding. Or did I not look in the right place....

HiddenVale - HV logo TalkPage 15:40, July 20, 2016 (UTC)

You place the code in MediaWiki:Common.js on your wiki. If the directions seem complicated, there is another script named ProfileTags which has the same function and is easier to configure.
-- Monochromatic Bunny 17:13, July 20, 2016 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.

Fandom may earn an affiliate commission on sales made from links on this page.

Stream the best stories.

Fandom may earn an affiliate commission on sales made from links on this page.

Get Disney+