FANDOM

Welcome to my talkpage! You can leave me a message about anything regarding the wiki, my scripts on it or general Fandom development here.

Messages left here will be answered to on your own talkpage. This is so you receive a talkpage notification when I reply to you.

Archives: 123

Untitled

I already posted this on the forum, just in case it doesn't get answered there. 

I'm having issues with Nitro. When I open the application and type my full Username and Password it tells me that it's wrong even though I typed it in right multiple times. (I signed into Wikia with my Google Account. Maybe that has something to do with it?)

  https://dev.fandom.com/wiki/User_talk:DivinityUnleashed

Untitled

ok so I don't really know how the talk pages work, but here's my problem with the wikia nitro

 

  Whenever I try to upload a gif, it always says the gif isn't a square, or it's over 512k

however, the gif I'm trying is a square and matches the file size, but it's still saying this. Can you help?

(BTW i know the current gif im using works, but every other gif doesn't)

I hope you can fix this!

Neptune_Ninja (talk) 00:49, June 25, 2020 (UTC)

The GIF im trying to upload is this:

Giphy (6)
Neptune_Ninja (talk) 15:40, June 25, 2020 (UTC)

hm ok.

Do you know of any compressers/ ways i can put the file size down? It said the file wasn't that large so it mustve been wrong —Preceding unsigned comment added by Neptune7Ninja2Comics (talkcontribs) . Please sign your posts with ~~~~!

 

i used that and got it down to 2.41 mb, but it wont go any lower. —Preceding unsigned comment added by Neptune7Ninja2Comics (talkcontribs) . Please sign your posts with ~~~~!

Untitled

Hi is there anyway to add a drop down menu other then the button but with a image

Gdbbsjxk | UMGE 12:45AM, October 11, 2020 AEST  

Untitled

Hi! hope you are having a great day. When i try to download Nitro on macOS it says that it can't be opened because it is from an unidentified developer. How can i fix this? —Preceding unsigned comment added by MarkNotFound (talkcontribs) . Please sign your posts with ~~~~!

Archive thread script problem

Did I import the script correctly?

https://community.fandom.com/wiki/User:UpnCbs06/common.js

UPNCBS06 - UTGE 20:43, July 12, 2020 (UTC)

Assistance on Halo Alpha

Hey Kocka!

I'm the only active bureaucrat on Halo Alpha and we are really trying to turn it around to make it a place that can compete in the current climate.

The coding on Halo Alpha is so very old. The CSS and JS are so out of date and it's a complete mess. We don't even know what css/js we have is needed and isn't!

I'm not good with coding, so I really want some help to try and tidy up Halo Alpha so we can make it a good place.

Would you be able to/know anyone who'd be willing to help?

Many thanks,

343TheGuiltyProphetGlobal Discussions Moderator 11:35, July 19, 2020 (UTC)

AjaxThreadDelete

Hello, I imported AjaxThreadDelete to my universal personal javascript, and I also have personal JavaScript enable, but for some reason it does not work for me, and no "delete" button pops up only "remove" and "close thread". Do you need to be an admin/mod for this plugin to work? Zazsch (talk) 22:06, July 27, 2020 (UTC)

Code corrections

Hi, KockaAdmiralac! I am just passing here to thank you for correcting MediaWiki:RCModule/code.js; I did not know you could not use let, although I should have supposed it after seeing it fail because of missing semicolons haha. Thank you so much! — bitomic (talk) 17:00, July 29, 2020 (UTC)

FandomizedChat

Greetings Cube,

I have read the post about Chat being defunct in the future. Because Chat is currently deprecated, it appears that the FandomizedChat script is no longer needed. Can you please delete those pages? Thank you in advance.

Ultimate Dark Carnage (talk) 18:23, August 6, 2020 (UTC)

Database dump request

Please request a database dump because hundreds of edits have been made since the last time a database dump was requested. And thus it complicates checking which pages require updating and whatnot. ― C.Syde (talk | contribs) 01:15, August 19, 2020 (UTC)

An auto dumper exists? Never would have guessed. ― C.Syde (talk | contribs) 09:01, August 19, 2020 (UTC)

UCP JavaScript changes

Hey Cube. I lack the requisite permissions to edit the UCP JavaScript changes page on the UCP wiki, so I figured I'd let you know of a few more issues I've noticed in the course of UCPifying my own code so you can make mention of them at your discretion.

  • $.timeago doesn't seem to work on UCP wikis. When passed a wellformed timestamp in any of the permissible formats, it returns only a value of "NaN years ago", "a minute ago", or undefined. This affects scripts like LastEdited, PageCreator, and UserAccountAge.
  • The RL module ext.wikia.LinkSuggest is presently unavailable for use on UCP wikis, though Staff told me a few weeks ago that this functionality will eventually be ported over in some form to the UCP. This affects scripts like AjaxEdit, MassEdit, and Message.
  • The point at which then callbacks attached to synchronous $.Deferred promises are executed differs timeline-wise on UCP and legacy wikis. On legacy wikis, then callbacks are synchronously executed immediately after their promises are resolved/rejected, even if this delays the execution of other synchronous code presently on the call stack. On UCP wikis, such callbacks are only executed once the synchronous code of a currently executing task has been handled by the event loop.

──────────────────────────────────────────────────────────────────────────────────────────────────── For example, the following code will result in messages being printed to the console in different orders:

console.log("Before resolve");
$.Deferred().resolve().then(console.log.bind(null, "Resolved"));
console.log("After resolve");

On UCP wikis, the order is...

Before resolve
After resolve
Resolved

...which is the way one would expect a native, spec-compliant Promise to act. However, legacy wikis print...

Before resolve
Resolved
After resolve

I assume this is a jQuery versioning issue. I'm not very familiar with how much $.Deferreds have changed over the years, but I would imagine this was done to bring them more into line with the expected execution behavior of native, spec-compliant Promises. It certainly seems $.Deferreds' then callbacks are now being treated as microtasks by the event loop and executed once the synchronous code of the currently executing task has completed, though this doesn't seem to extend to done and fail callbacks for some reason.

I dunno; this is a comparatively minor issue, but it might be worth mentioning because it's been causing me a few headaches in the course of updating my own code. Sorry for the lengthy message. Cheers! EIZEN (talk) 12:38, August 22, 2020 (UTC)

Thanks for the reply! As far as timeago formatting is concerned, I've been passing ISO 8601 Extended Format string arguments like "2017-09-01T23:37:07Z" and new Date instances formatted like new Date("2017-09-01T23:37:07Z") directly to $.timeago. On UCP wikis, I get back some useless value (usually undefined) while legacy wikis provide the expected string. For example, both...

────────────────────────────────────────────────────────────────────────────────────────────────────

$.timeago("2017-09-01T23:37:07Z");

...and...

$.timeago(new Date("2017-09-01T23:37:07Z"));

...give me a value of "two years ago" on legacy wikis but undefined on UCP. Oddly enough, the snippet you provided does work for me; maybe the inconsistent behavior exhibited when passing ISO timestamps/Date objects with timestamps directly should be mentioned? Cheers! EIZEN (talk) 14:31, August 22, 2020 (UTC)

WHAM

Trying, and failing, at adding the WHAM feature to remove a vandal.—Preceding unsigned comment added by TheDoctorX (talkcontribs) 22:36, August 26, 2020 (UTC). Please sign your posts with ~~~~!

Yay! That was easier than I thought! Thanks for the help!

TheDoctorX (talk) 04:07, August 28, 2020 (UTC)

"File:Snake throbber dark-bg.gif (Unused; marked for deletion)"

What do you mean unused? We use that, it was the best of the bunch! Is this somehow related to the whole UCP movements or something? Starring: DEADWEIGHT 14:45, August 29, 2020 (UTC)

Thanks a bunch. I uploaded it to our own wiki, so you can delete your copy of the file if you wish. Still, why it was deleted in the first place? Options are nice. Starring: DEADWEIGHT 15:03, August 29, 2020 (UTC)
Welp, and I only just noticed that link with generator even exists huh. Maybe I might use it to adjust the throbber further to my tastes even, though it just so happens the one you had was already perfect for what we're using on our wiki. Thanks again. Starring: DEADWEIGHT 15:18, August 29, 2020 (UTC)

Advise needed

Hi there! Writing to you because I honestly don't know who to ask in the odd occurrence I found myself in; I kind of feel like if it's Fandom's issue then I should be going to actual Staff, but the problem is scripts (that previously worked fine, like 16 hrs ago, around the "pause" announcement,) suddenly not showing/working on un-migrated communities. I haven't touched my global.js since Feb 2019, and I don't think the ones I'm now not seeing have been updated in the time span that they went from showing and not showing. I discovered the following suddenly missing from my un-migrated communities:

It's weird because FileLogs‎, View Source, and QuickLogs all appear to be working on UCP (I can't tell if I'm seeing images formatted as OldFilePages due to the result of installing the script, or it really is just like that,) but not on a legacy wiki (which they worked fine hours ago,) the lost of ManageReferences isn't too terrible but I noticed it hence listing, lastly MarkForDeletion is kinda the weirdest, like, here on Dev and on CC, it actually appears for me, but not on communities where I have additional rights? This is also the only one that has UCP compatibility stated as "Ready" but not showing up for me in a UCP community (where I happened to have additional Rights.)

I think it's odd because I do have other scripts installed, and at the moment, they appeared to be fine. I couldn't figure out a pattern. At first I thought it was those two scripts being weird (that's why I went individually writing on their talk pages,) but then I found more that mysteriously stopped working.

No idea who to ask about this. Do you have any idea why this is happening? Or who I should be taking this to? If needing to be more concrete (I have no idea where the problem actually lies,) I'm experiencing the above missing on w:c:harrypotter where I'm a Content Moderator and w:c:lockwoodandco where I'm b-crat. (I haven't checked other communities where I have Rights.)

Sorry if the majority of the mentioned is out of your control or have no knowledge about (I tend to just generalized everyone being knowledgable on Dev,) in that case, still thanks for finish reading this. --Sammm✦✧(talk) 06:01, September 1, 2020 (UTC)

Hey there! Thank you so so much for replying to what I left for OldFilePages! This is now getting weirder and I'm somewhat more sure that the problem is likely on my end (though I still have no idea why); upon seeing your reply for OldFilePages, I went checking on Safari (logged in) on my iPhone (though using full site to view,) and on there, it worked. I was like, okay, maybe it's a browser problem. I then tried again with Safari on my desktop... And it doesn't work. (It's like that for all file namespace, but I'm on w:c:harrypotter at the moment.) When I reported this, I was using Chrome on desktop, and it's still not working. Tried bypassing my browser's cache for both Safari and Chrome and it's still like that. (That and the fact I hadn't changed anything for this to happen, was just... odd.) I'm not sure why, but all of the above (sans MarkForDeletion) appears to be working on my phone but not my desktop, nothing on which I have updated during the time. I was really hoping it was a browser problem when Safari on my phone worked... Now I'm just confused as to why it worked on one (not-exactly-suitable) device and not another. Dx
Thank you for taking the time to answer. I feel so silly because I'm likely the only one experiencing this, it seems? Just weirded out as it makes no sense to me lol. --Sammm✦✧(talk) 08:35, September 1, 2020 (UTC)
OMG.... I'm officially like WTF. I mean, it's not like I'm every going to use Safari on my iPhone as a primary editing device, but I've jinxed myself. Now even there, the ones I thought were just missing from my browser on my desktop, also disappeared on my phone. I wished I had screenshot when they had been showing 10 minutes ago, including ManageReferences no less! I think I'll screenshot everything that's not working and go to Staff. This is just bizarre.
Do you have any additional suggestion as to how to order w:User:Sammm鯊/global.js? Most of the stuff seemed to be working, but it's true that what's under QuickLogs are seemingly the ones not working. I'll move it to the bottom as you suggested. Fingers crossed it'd solve the weirdness. --Sammm✦✧(talk) 09:00, September 1, 2020 (UTC)
Sorry for replying in short span of time. Heading out soon but the quick update is that, after moving QuickLogs to the bottom, View Source and ManageReferences both seemed to appear now. (The rest isn't.) Maybe my browser would catch up like 10 hours later or something. Thanks again for suggesting to move it, at least I got 2 things back working! --Sammm✦✧(talk) 09:10, September 1, 2020 (UTC)

Your edit at UCP

Before removing archived script, please replace first. Or they'll confuse for your action.--*Lac*() 13:34, September 9, 2020 (UTC)

If a script is archived and does not work on the UCP, it will be deleted after UCP Phase 1. The "Archived" status means that a script is receiving no further updates, so it won't be fixed on the UCP if it does not already work.
  • Just this. It says also If a script is migrated and old one does not work on the UCP, old one will be deleted after UCP Phase 1. Must notice to all of archived script creator --*Lac*()

CSS loading without instalation

How and why the MediaWiki:BlendGlobalNav.css loads and makes the nav bar light when I visit the article BlendGlobalNav? Is this an expected behavior, applied to demonstrate how it works? It's loading on my side after this request:

dev.fandom.com/load.php?debug=false&lang=en&mode=articles&skin=oasis&missingCallback=importNotifications.importArticleMissing&articles=MediaWiki%3ABlendGlobalNav.css&reviewed=1599244285&only=styles

This is odd because the article itself does not mention the code is currently being applied.

I noticed the same thing on these articles:

Sapador Castelo (talk) 20:29, September 9, 2020 (UTC)

Geez! Good to know! I couldn't find where the load was coming from! Thanks!
Sapador 23:14, September 9, 2020 (UTC)

"I'm not sure why would they care about"

...Fine, I just thought you thought no one cares. Just add notice at inside of script.

And we have deleted things at DemoScripts.js. --*Lac*() 21:10, September 9, 2020 (UTC)

Move request

Hi Kocka, can you move the "Solarized Syntax Highlight for Articles" to "SolarizedSyntaxHighlight"? The "articles" on title was about a limitation that no longer exist on UCP. The code is updated for the new wikis where it works on all namespaces. \o/ The only pages actually linking to it is my user page (not important) and Dev Wiki:UCP.
Sapador 05:37, September 10, 2020 (UTC)

Untitled

Can I be like joining the FANDOM staff? Is it possible? AFR 2281 (talk) 21:29, September 11, 2020 (UTC)

UCP test wiki

Is there one where scripts can be tested? -- Khang (talk) 16:50, September 26, 2020 (UTC)

Thanks. Khang (talk) 03:21, September 27, 2020 (UTC)

MediaWiki:PageRenameAuto-update/code.js

Hello,

Do you think this code can be maintained for UCP ?

Regards,

Louky (discussion) 18:46, September 30, 2020 (UTC)

Untitled

Hi,

 

  Have been trying to install pseudomonobook for an hour. I have it on all wikis except on the only wiki I actually care about /v/'s recommended games, which is actually unusable without the skin/theme.

edited "https://community.fandom.com/wiki/User:Biquet/global.css" with the import statement and cleared my cache multiple times.

 

  I don't know why installing a theme has to be that hard either, even more as it's vastly superior to the base skin.

 

  Biquet (talk) 19:20, September 30, 2020 (UTC)

WikiaActivityLogger

I used to use the WikiaActivityLogger script before it went kaput and its replacement's GitHub page states to contact you if such was the case, so here I am, better late than never. Is this still a thing?

PLASMOIDTHUNDER (user | talk) 23:20, October 5, 2020 (UTC)

Profile

Hello can my profile which is link here please be delete because I request it to be delete? & also, you can use this link to delete the pages. Thanks White44Tree (talk) 02:31, October 9, 2020 (UTC)

AjaxDiff edit

Hello and thank you for the information on AjaxDiff and $.showCustomModal. Unfortunately, I didn't find a fitting status for "broken and may not end up fixed", so I picked "blocked". "Awaiting" seems to imply this is being worked on, which I can't assert for that script. I believe it's suboptimal (and misleading) to leave scripts known to be not working as "unknown". Maybe another status could be implemented? --AttemptToCallNil (talk) 20:38, October 9, 2020 (UTC)

Hello

since can't edit modules in english UCP wiki, author can't check by own hand. Can you check is global Lua modules working in UCP?--*Lac*() 13:57, October 11, 2020 (UTC)

Dessamator is missing or inactive--*Lac*() 14:27, October 11, 2020 (UTC)

Can you notice anyone can be maintainer?--*Lac*() 21:07, October 11, 2020 (UTC)

Deleted comments and messages

Hi, KockaAdmiralac

Could you help me creating a script to hide deleted comments and messages wiki wide?

I have this JQuery that worked when used directly on my browser:

$('#articleComments div[class^="Comment_wrapper"]:has(div[title="Deleted"])').hide();
$('#MessageWall div[class^="Message__wrapper"]:has(div[title="Deleted"])').hide();

That I don't know how to implement on a MediaWiki JS page.

Could this be done with regular JS, without JQuery? Sapador Castelo (talk) 16:04, October 12, 2020 (UTC)

User Avatar Finder Incompatible with UCP

Hello! My wiki was migrated over to UCP, but on my wiki template, the avatar is not showing up. I was wondering why? 『 ScarletRose223 』(TALK) 00:24, October 14, 2020 (UTC)

Tabs not showing in infobox

This page should have two tabs within the character infobox but none of the tabs actually show up on it now. Not sure why this issue is happening as both the page and infobox were fine before the wiki migrated to UCP. 

2Wiings (talk) 23:12, October 15, 2020 (UTC)

TopEditors script

Hello! Why it doesnt work on UCP? Status saying that its ready. Bumbarek (talk)

Community content is available under CC-BY-SA unless otherwise noted.

Fandom may earn an affiliate commission on sales made from links on this page.

Stream the best stories.

Fandom may earn an affiliate commission on sales made from links on this page.

Get Disney+