FANDOM

SlyCooperFan1

Wiki Manager Councilor
  • I live in New York
  • I am Male
  • Bio Sly has been editing on Fandom wikis for over 10 years and currently works as a Gaming Wiki Manager.
  • [Show More]

Welcome

Hi, welcome to Fandom Developers Wiki! Thanks for your edit to the User talk:Cqm page.

Please leave a message on my talk page if I can help with anything! Cqm (talk) 03:32, May 21, 2016 (UTC)

SavedDrafts

Hello! Could you please archive your SavedDrafts code? Drafts are gone and probably Fandom isn't going to re-enable this feature so archival would be the best.

Cheers, RAIL my talk 18:29, October 17, 2019 (UTC)

You have to add template below languages box and change status in infobox just like I did here.

RAIL my talk 05:52, October 18, 2019 (UTC)

Re: EraIcons

I've UCPified the JS code. The script should append icons to the proper location on UCP wikis now, but the CSS has outstanding display issues related to the position: absolute; style applied to .page-header__eraicons. You'll want to ping Ursuul to review and adjust the CSS file—he wrote it, so I don't want to mess around with its contents without his approval. EIZEN (talk) 10:27, October 7, 2020 (UTC)

All taken care of. Tested the modern JS & CSS on Ace Combat 7: Skies Unknown (legacy) & Thomas Raith (UCP), no issues on either. Thanks Midas!
UrsuulTalkCMDate5:05 PM Wednesday, October 7, 2020 (UTC)
As far as I can tell, this wasn't technically a fault of EraIcon's, per se—as you said, the script worked a little too well. The problem was some unexpected interference between EraIcons and AddRailModule over the latter's firing of the wikipage.content hook. EraIcons handled the issue Ursuul brought to my attention by removing and reapplying the icons every time this hook was fired, which usually only happens during the initial page load and when a new edit is submitted using the UCP's 2017 VisualEditor. I failed to account for another script's usage of the same hook.

In the case of the page you linked, EraIcons cleared the header and added the icons during the first hook, encountered AddRailModule's refiring of the hook, and cleared the header again while attempting to re-add the icons. Since the icon divs had already been moved from the page body to the header the first time, there was nothing to add, hence the lack of icons. My patch should work fine once approved by Staff. EIZEN (talk) 23:55, October 17, 2020 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.

Fandom may earn an affiliate commission on sales made from links on this page.

Stream the best stories.

Fandom may earn an affiliate commission on sales made from links on this page.

Get Disney+